Studio 3D Model File Importing Guide

Article last updated:

This guide provides tips for exporting models from other programs for viewing in zSpace Studio.
We recommend that if this is your first time working with 3D models, you create your model in Leopoly.
For more advanced 3D model creators, we recommend creating a Collada (.dae) file of your 3D model
masterpiece. In this guide, we’ve included our notes on best practices for successful Studio model
import.

Table of Contents

Importing Your Model into zSpace Studio

  1. Open the Sandbox in Studio.
    • Page-2-Image-2.jpg
  2. Select the Backpack in the upper right of the Studio window.
    • Page-2-Image-3.png
  3. Click on the “Import File” button.
    • Page-2-Image-4.png
  4. Navigate through the file browser to find the model file you want to import. Only supported model file types will appear.
  5. Click on the desired file to load it in Studio. The model will appear in the scene.

zSpace Studio File Import Q & A

Q: I found a model online, can zSpace Studio load it?

A: Take a look at the Assimp Open Asset Import Library webpage: http://assimp.sourceforge.net/main_features_formats.html

If the model you found has a file type that matches one listed on that page, Studio will attempt to load it
for you! At zSpace, we have had the most success importing the following file types:

  • .dae
  • .stl
  • .obj

Q: I want to make a model myself! How can I make something and see it in
Studio?

A: We recommend using Leopoly. The Leopoly software is loaded on every zSpace system so you already
have the tool you need to create your own 3D model!

See our How to Leopoly video at http://edu.zspace.com/info/leopoly to get started.

Q: What file formats can zSpace Studio load?

A: Studio uses the Assimp Open Asset Import Library, so the application will attempt to load the file formats on that list. Successful import is based on several factors, so while we cannot guarantee loading just based on file type, we do see most success with the following file types:

  • .dae
  • .stl
  • .obj

You can view the list of files that Studio will attempt to load here: http://assimp.sourceforge.net/main_features_formats.html

(Note: Currently, an FBX file from 2011, 2012, or 2013 can be opened in Studio. FBX files from other
years are not supported. See the next question for one way to get an FBX file for those three years.)

Q: How do I get an FBX file from 2011, 2012, or 2013 into zSpace Studio?

Page-4-Image-7.gif

A: If you are using Autodesk Maya, you can change the year for the exported FBX in the ‘Export
Selection’ window.

Click File -> Export Selection and scroll down to the bottom of the options panel on the right side of the
window. Expand FBX File Format and select 2011/2012/2013 from the dropdown menu.
Other programs may have similar export options to select the exact year for the exported FBX.

Q: Can Studio load a parametric model?

A: zSpace Studio can only load polygonal models. If your model is parametric, it will not load in Studio. It
must be converted to a polygonal file type to load into Studio.

Q: What if I find a model in a format that is not supported by Studio?

A: You may be able to use one of the programs below to open the file and save it as a file type that
Studio will attempt to open.

Use the table below to find which of the programs highlighted in this guide will open/import your model
file. If one of the programs listed can open the file, you can then re-export that file in a Studio-friendly
format.

NOTE: When changing the type of file through one of the programs below, details about the model may change. For example, the model may no longer have its materials, or the model may be one piece instead of dissectable.

Program Name Can Open / Import File and Export in a format Studio will recognize
AutoCAD .dwg / .dws / .dxf / .dwt
Autodesk 3ds Max .3ds / .ai / .apf / .asm / .catpart / .catproduct / .cgr / .chr / .dae / .dem / .ddf / .dlv / .dlv3 / .dlv4 / .drf / .dwg / .dxf / .exp / .fbx / .flt / .htr / .ige / .iges / .igs / .ipt / .iam / .jt / .max / .mdl / .model / .obj / .prj / .prt / .sat / .session / .shp / .skp / .sldasm / .sldprt / .stl/ .stp / .step / .trc / .wire / .wrl / .wrz / .xml
Autodesk Inventor  .3dm / .brd / .CATpart / .cgr / .dwf / .dwg / .dxf / .iam / .ide / .igs / .ipn / .ipt / .jt / .prt / .rvt / .sat / .sldasm / .sldprt / .smt / .stl / .stp / .wire / .x_b / .x_t
Autodesk Maya  .dae / .fbx / .igs / .ipt / .ma / .mb / .stl / .stp / .step
You can find plug-ins to open more file types online.
Blender .3ds / .blend / .bvh / .dae / .fbx / .obj / .ply / .stl / .svg / .wrl / .x3d
Leopoly .obj / .stl
MeshLab .aln / .apts / .asc / .bre / .ctm / .dae / .gts / .mlp / .nvm / .obj / .off / .out / .pdb / .ply / .pts / .ptx / .qobj / .stl / .tri / .txt / .vmi / .wrl / .x3d / .x3dv / .xyz
SketchUp .3ds / .dae / .dem / .ddf / .kml / .kmz / .skp / .stl
Solidworks .3dm / .ai / .asm / .asmdot / .bdf / .brd / .cgr / .ckd / .dll / .drw / .drwdot / .dwg / .dxf / .emn / .ifc / .iam / .ibd / .iges / .igs / .ipt / .lfp / .par / .prt / .prtdot / .psd / .psm / .sat / .sldasm / .slddrw / .sldlfp / .sldxml / .stl / .step / .stp / .vda / .wrl / .x_b / .x_t / .xas / .xmt_txt / .xpr

Q: Should my 3D model file be created with NURBS or polygons?

A: zSpace Studio can only load models that are made with polygons. Studio was made using Unity and Unity does not support NURBS. If your 3D model uses NURBS, you must convert those NURBS to polygons before you can successfully import your model into Studio.

Q: My imported model appears all white and/or has red marks all over it. Why?

A: Models appear red and white when Studio cannot locate the model’s attached materials or textures. This is a pathing issue. Studio’s import process works best when you import a model from the exact same location that you previously exported it to. If the path name associated with the material or texture changes after the export, Studio is unable to find them on import. Embedding media can help to prevent materials and textures from being lost on import.

3D Modeling: Technical Tips from our Design Team

Recommended Modeling Programs

  1. Leopoly, for the beginning artist
    • This is a model creation software provided with every zSpace. It has a simple interface. It
      is easy to create and color models.
    • zSpace has worked closely with Leopoly to iron out a reliable exporting and importing workflow. zSpace Studio can easily open the OBJs exported from Leopoly.
  2. Autodesk Maya, for technical artists
    • Create high-quality models with textures. Artists working at zSpace use this software to create models that we include in our STEM applications.
    • Maya can open many different file types by default and there are many plugins available online to increase Maya’s import capabilities even further. (zSpace is not responsible for any plugins you may choose to download.)
    • Exports Collada (.DAE) files. A DAE file is the best type of model file to import into Studio because utilizes materials and textures, but is also a very efficient file type for its size.

Model Creation Best Practices for Unity

zSpace Studio uses the Unity3d engine for rendering. What follows are some best practices for creating
assets with Autodesk Maya (or equivalent 3d program) with the Unity3d engine in mind.

Geometry

  • Model in quads or triangles. No ngons (an ngon is a face or polygon that is made up of five or more sides or edges connected by five or more vertices.)
  • Backfaces are culled in Unity3d (rendered invisible). In order to render backfaces visible, make your model two-sided with normals facing inward and outward.
  • Unity 3D has a 50k polygon limit and 32k vertex limit for a single mesh. Design your assets appropriately or Unity3d will subdivide it at an arbitrary location(s) on the mesh (This is important to keep in mind for assets that require exact dissecting.)
  • Models that you want to be dissected in Unity need to be segmented in Maya. Dissected parts of a model should be parented under a group node. Grouped models will export as a single unsegmented mesh if parented under a shape node.
  • The model scene scale should be in meters with +Y up, scaled at 1:1.
  • When combining meshes in Maya use Mesh > Combine option box > Merge By UV links. This will preserve all the UV sets (if any) and they must be copied to map1 in the UV Texture Editor. Delete any UV sets not in map1.
  • Harden and soften edges where needed.
  • Before animating, delete history on the mesh.

Texturing

  • Studio supports diffuse, specular, normal, reflective, emissive, and transparency maps. However, the specular, reflective, emissive, and transparency maps can individually only be used by mapping them to the alpha channel of the 32 bit diffuse map.
  • UVs must be in the 1,1 Coordinate System.
  • All UV sets should be copied to "map1" in the UV Editor. UV sets not copied to map1 will not display textures in Unity.
  • The following texture file formats are recommended: TGA and PNG.
  • Use TGA in transparent textures with edge padding applied to the UV islands.

Exporting

  • The model should be at the origin and facing +Y up.
  • Before exporting, freeze all transforms on all meshes. The origin or pivot point of a mesh can be anywhere in space as long as the mesh’s translate, rotate, and scale is frozen.
  • If the option is available when exporting, ensure that “embed media” is enabled in the export
    options.
  • Export meshes using FBX.

Exporting Models for Use in zSpace Studio

Leopoly

This section guides you through exporting a 3D model file in Leopoly that results in a format supported by zSpace Studio. This guide focuses on converting a model into an .OBJ file.

  1. Create a folder on your computer to save your Leopoly OBJ model in. (We recommend creating
    a unique folder for each model in order to stay organised!)
  2. Sculpt a model in Leopoly.
  3. Click on the “Save Object” icon in the upper right corner.
    • Page-8-Image-12.png
  4. In the save window, choose your created folder as the save location and name your model file. Make sure “Save as Type” has “*.obj” selected.
    • Page-8-Image-13.png
  5. Click on “Save”.
  6. If you added color to your model, some .jpg, .mtl, and .properties files were saved to the same file location as the OBJ model file - they contain the colors and prints of your model. All of these files share the same name as the model and must be in the same folder as the OBJ file in order to be viewed by Studio.
    • Page-8-Image-14.jpg
  7. Now that you have a folder containing a model file and some color/texture files, you can send this entire folder via email or USB to share and view on other zSpace systems.

What will my model look like in zSpace Studio?

Here are things to expect when viewing an .OBJ file from Leopoly:\

  • Leopoly OBJ models will not be dissectible in Studio.
  • If you add colors to your model in Leopoly, Studio will show them.
  • When dissecting your OBJ model, the colors may dissect as separate pieces.
  • OBJ files show external geometry and surface details.
  • The model will be hollow inside.
  • Page-32-Image-81.png

Autodesk Maya

This section guides you through exporting a 3D model file in Autodesk Maya that results in a format supported by zSpace Studio. These instructions were created using Autodesk Maya 2014. Other versions may have slightly different workflow paths. This guide focuses on converting a model into a .DAE file.

  1. With your model open in Autodesk Maya, click on “Modify” > “Freeze Transformations.” Otherwise the pieces of your model may scatter across the scene when loaded into Studio. Your model will still be dissectible by group in Studio.
    • Page-10-Image-18.jpg
  2. Select “Edit” > “Delete All by Type” > “History” to remove any extra information that could
    impact what your model looks like in Studio.
    • Page-11-Image-20.jpg
  3. Highlight your entire model. It will appear green or white. Then, under “File”, select “Export Selection...”
    • Page-11-Image-21.jpg
  4. Make sure the “Files of Type” field has “DAE_FBX export” selected.
    • Page-12-Image-23.png
  5. Click on “Export Selection”

What will my model look like in zSpace Studio?

Here are things to expect when viewing a .DAE file:

  • DAE files show materials, textures, and colors. They appear how they looked in the program that created them.
  • DAE files show external and internal geometry. This means you will be able to see internal parts of the model.
  • Any pieces you defined as individual segments appear in Studio as dissectible parts. You can dissect your model accordingly.
  • Page-12-Image-25.png

Alternative Method Using a Plugin

We have also had success when using a plug-in called COLLADAMaya.mll to obtain an OpenCOLLADA (.DAE) file. This is not an official recommendation and we can not provide support for use of this plug-in; anything you choose to download onto your computer is done at your own risk.

  1. Complete steps 1-3 from the Maya section that does not use this plug-in.
  2. Make sure the “Files of Type” field has “OpenCOLLADA exporter” selected.
    • Page-12-Image-24.png
  3. Click on “Export Selection”.

What will my model look like in zSpace Studio?

Here are things to expect when viewing a .DAE file:

  • DAE files show materials, textures, and colors. They appear how they looked in the program that created them.
  • DAE files show external and internal geometry. This means you will be able to see internal parts of the model.
  • Any pieces you defined as individual segments appear in Studio as dissectible parts. You can dissect your model accordingly.
    • Page-13-Image-27.png

Solidworks

Solidworks models do not retain their materials or parts hierarchy when converted to a file type that zSpace Studio can recognize.

What will my model look like in zSpace Studio?

Here are things to expect when viewing a .STL file:

  • STL files do not show colored materials or textures. These models appear as a single solid color
    (usually white or grey).
  • STL files show external geometry and surface details only.
  • STL files are often used for 3D printing, so you can use zSpace Studio to view what your STL file looks like before it is 3D printed.
  • Page-14-Image-30.png

How to export Solidworks files to .STL

This section guides you through exporting a 3D model file in Solidworks that results in a format supported by zSpace Studio. These instructions were created using Solidworks 2014. Other versions may have slightly different workflow paths. This guide focuses on converting a model into a .STL file.

  1. With your model open in Solidworks, hover over the grey arrow pointing to the Solidworks logo
    to bring up the “File” menu.
    • Page-14-Image-29.jpg
  2. In the “File” menu, select “Save As...”
  3. Make sure the “Save As Type” field has “STL” selected.
    • Page-15-Image-32.png
  4. Click on “Options” in the lower left of the “Save As” window. Make sure these options are
    selected:
    • Under “Output as” make sure ACSII is selected, not Binary.
    • Check the box that says “Save all components of an assembly in a single file.”
    • Page-15-Image-33.jpg
  5. Click on “Save”.

Alternative Method Using a Macro Creates an .OBJ File

We have also had success when using a macro called Free SolidWorks OBJ Exporter v2 to obtain an .OBJ
file. The OBJ file type created by Solidworks is different than the type created by Leopoly and the model materials and parts are not retained. You can download the macro here:https://forum.solidworks.com/thread/54270 This is not an official recommendation and we can not provide support for use of this macro; anything you choose to download onto your computer is done at your own risk.

Macro Installation

  1. Bring a model into SolidWorks 2014 that you want to export as an OBJ.
  2. Click the Options button on the far right of the top toolbar.
  3. Click Customize.
    • Page-16-Image-35.png
  4. Click the Commands tab.
  5. Select Macro from the category list.
  6. Under Buttons, select New Macro Button and drag the icon onto the SolidWorks toolbar where you want it to appear.
    • Page-16-Image-36.jpg
  7. A dialog appears:
    • Select the macro file to link the button to (swp file).
    • In the Method dropdown, select “modSWtoOBJ.InitialUI”.
    • Choose an image and tooltip for the button. The folder from the link above contains an image for the button.
    • Leave prompt as default.
    • Page-17-Image-38.jpg
  8. Click “Ok” and the button will appear.
    • Page-17-Image-39.png

Export Process

  1. Click your new OBJ export button. A dialog appears. I left all options as default.
    • SolidWorks will ask you to save your file before exporting to OBJ. You must perform this save.
  2. Click Run Exporter.
    • Page-18-Image-41.jpg
  3. SolidWorks will think for a bit while it exports. Wait time is dependent on the complexity of the model. SolidWorks can seem like it has hung or crashed, but do not force-close it.
  4. You will receive a message. This message will inform you of success or failure. Examples of an error message (left) and a success message (right).
    1. Page-18-Image-42.pngPage-18-Image-43.png
  5. A folder appears in same directory as the model file you saved -- “[model name] OBJ”
    • Folder contains an OBJ file and a MTL file.

Autodesk 3ds MAX - Creating a DAE file

This section guides you through exporting a 3D model file in Autodesk 3ds Max that results in a format supported by zSpace Studio. These instructions were created using Autodesk 3ds Max 2014. Other versions may have slightly different workflow paths. This guide focuses on converting a model into a .DAE file.

  1. With your model open in Autodesk 3ds Max, hover over the grey arrow pointing to the 3ds Max logo to bring up the “File” menu
    • Page-19-Image-45.jpg
  2. In the “File” menu, select “Export”.
  3. Make sure the “Save As Type” field has “Autodesk Collada (*.DAE)” selected.
    • Page-19-Image-46.png
  4. Click on “Save”.

What will my model look like in zSpace Studio?

Here are things to expect when viewing a .DAE file:

  • DAE files show materials, textures, and colors. They appear how they looked in the program that
    created them.
  • DAE files show external and internal geometry. This means you will be able to see internal parts of the model.
  • Any pieces you defined as individual segments appear in Studio as dissectible parts. You can dissect your model accordingly.
    • Page-20-Image-48.png

Autodesk AutoCAD - Creating an STL file

This section guides you through exporting a 3D model file in Autodesk AutoCAD that results in a format supported by zSpace Studio. These instructions were created using Autodesk AutoCAD 2016. Other versions may have slightly different workflow paths. This guide focuses on converting a model into an .STL file.

  1. With your model open in AutoCAD, click on the red ‘A’ logo in the top left corner to access the
    file menu.
    • Page-21-Image-50.jpg
  2. In the “File” menu, select “Export”, then “Other Formats.”
  3. Make sure the “Files of type” field has “Lithography (*.stl)” selected.
    • Page-21-Image-51.png
  4. Click on “Save”.

What will my model look like in zSpace Studio?

Here are things to expect when viewing a .STL file:

  • STL files do not show colored materials or textures. These models appear as a single solid color (usually white or grey).
  • STL files show external geometry and surface details only.
  • STL files are often used for 3D printing, so you can use zSpace Studio to view what your STL file looks like before it is 3D printed.
  • Page-22-Image-53.png

Autodesk Inventor - Creating an STL file

This section guides you through exporting a 3D model file in Autodesk Inventor that results in a format supported by zSpace Studio. These instructions were created using Autodesk Inventor 2016. Other versions may have slightly different workflow paths. This guide focuses on converting a model into an .STL file.

  1. With your model open in Inventor, click on the orange ‘I’ logo in the top left corner to access the “File” menu.
    • Page-23-Image-55.jpg
  2. In the “File” menu, select “Export”, then “CAD Format.”
  3. Make sure the “Save As Type” field has “STL Files (.stl)” selected.
    • Page-23-Image-56.png
  4. Options can be left as default.
    • Page-24-Image-58.jpg
  5. Click on “Save”.

What will my model look like in zSpace Studio?

Here are things to expect when viewing a .STL file:

  • STL files do not show colored materials or textures. These models appear as a single solid color
    (usually white or grey).
  • STL files show external geometry and surface details only.
  • STL files are often used for 3D printing, so you can use zSpace Studio to view what your STL file
    looks like before it is 3D printed.
    • Page-24-Image-59.png

Blender - Creating a DAE file

This section guides you through exporting a 3D model file in Blender that results in a format supported
by zSpace Studio. These instructions were created using Blender 2015. Other versions may have slightly
different workflow paths. This guide focuses on converting a model into a .DAE file.

  1. With your model open in Blender, open the “File” menu, select “Export,” and then select “Collada (Default) (.dae).”
    • Page-25-Image-61.jpg
  2. In the export window, name your model file. The file name appears in the box highlighted with red.
    • Page-25-Image-62.png
  3. Make sure the file extension after the file name is “.dae.”
  4. Click “Export COLLADA” on the far right of the export window.
    • Page-25-Image-63.png

What will my model look like in zSpace Studio?

Here are things to expect when viewing a .DAE file:

  • DAE files show materials, textures, and colors. They appear how they looked in the program that created them.
  • DAE files show external and internal geometry. This means you will be able to see internal parts of the model.
  • Any pieces you defined as individual segments appear in Studio as dissectible parts. You can dissect your model accordingly.
    • Page-26-Image-65.png

MeshLab - Creating an STL file

This section guides you through exporting a 3D model file in MeshLab that results in a format supported by zSpace Studio. These instructions were created using MeshLab 2014. Other versions may have slightly different workflow paths. This guide focuses on converting a model into a .STL file.

  1. Open or load your model in the scene. You can drag your model file into the scene to load it. Make any last-minute changes to your model, if necessary. You will not be able to edit your model in Studio.
  2. With your model open in MeshLab, open the “File” menu and select “Export Mesh As...”
    • Page-27-Image-67.png
  3. Make sure the “Files of type” field reads as “STL File Format (*.stl).”
    • Page-27-Image-68.png
  4. Click on “Save”.

What will my model look like in zSpace Studio?

Here are things to expect when viewing a .STL file:

  • STL files do not show colored materials or textures. These models appear as a single solid color (usually white or grey).
  • STL files show external geometry and surface details only.
  • STL files are often used for 3D printing, so you can use zSpace Studio to view what your STL file looks like before it is 3D printed.
    • Page-28-Image-70.png

SketchUp - Creating an STL file

This section guides you through exporting a 3D model file in SketchUp that results in a format supported by zSpace Studio. These instructions were created using SketchUp 2014. Other versions may have slightly different workflow paths. This guide focuses on converting a model into a .STL file.

  1. With your model open in SketchUp, open the “File” menu and select “Export STL...”
    • Page-29-Image-72.jpg
  2. In the export options window, make sure the box is checked for “Export selected geometry only.” You can choose your export units. Both ASCII and Binary work as a file format.
    • Page-29-Image-73.png
  3. In the next dialog window, name your model file. The “Save as type” field can be left blank.
    • Page-29-Image-74.png
  4. Click on “Save”.

What will my model look like in zSpace Studio?

Here are things to expect when viewing a .STL file:

  • STL files do not show colored materials or textures. These models appear as a single solid color
    (usually white or grey).
  • STL files show external geometry and surface details only.
  • STL files are often used for 3D printing, so you can use zSpace Studio to view what your STL file looks like before it is 3D printed.
    • Page-30-Image-76.png

Tinkercad - Creating an OBJ file

This section guides you through exporting a 3D model file in Tinkercad that results in a format supported
by zSpace Studio. These instructions were created using Tinkercad’s website. This guide focuses on converting a model into an .OBJ file.

  1. Create a model in Tinkercad.
  2. Highlight your entire model. It will appear blue or purple. Then, under “Design”, select“Download for 3D Printing”
    • Page-31-Image-78.png
  3. Click on the OBJ button.
    • Page-31-Image-79.png
  4. The download automatically begins and appears in your Downloads folder. The downloaded zip folder has the name of your model.

What will my model look like in zSpace Studio?

Here are things to expect when viewing an .OBJ file from Tinkercad:

  • OBJ files show external geometry and surface details.
  • The model will be hollow inside.
  • If you add colors to your model in TInkercad, Studio will show them.
  • Your model will be dissectible. Pieces of the same color dissect as a group.
  • The model dimensions shown in Tinkercad will also be shown in Studio.
    • Page-32-Image-81.png

 

 

 

 

 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments